Dll loading error with pyinstaller + ctypes.cdll

When I try to running exe file which created with pyinstaller+pyqt5, always has error messages like

Traceback (most recent call last):

File “PyInstaller\loader\pyiboot01_bootstrap.py”, line 144, in init

File “ctypes_init_.py”, line 373, in init

FileNotFoundError: Could not find module ‘./FSetAccessibility.dll’ (or one of its dependencies). Try using the full path with constructor syntax.

But when I run the program with IDE, or run the exe file in my personal notebook,
it is running with no any error…
I already tried (Recipe Win Load External DLL · pyinstaller/pyinstaller Wiki · GitHub), still not working…

please help… OTL

Hi @He_Han

That’s an unusual error – when I Google it, all I find is this post :smiley:

Do you have any idea what FSetAccessibility.dll is ? These kinds of errors not happening on your own computer are because you have that file available (probably under /Windows/System/ or /Windows/System32) but other computers do not.

We either need to figure out how to package that file with your software, or figure out what we need to change so that file isn’t needed.