Recommended way to install Pyqt5 with fbs python Macos

All the stuff ive seen and tried seem to not work or install unsupported python/pyqt5 version for fbs and paths and compiling is a nightmare when it comes to getting Qtwebengine and its bits copied properly.

fbs requires old as hell pyinstaller and python so the homebrew installations for pyqt installs unsupported combination.

Has anyone recently setup a fresh MacOS fbs environment and possibly noted how they did so with or without homebrew and specific python versions and installer links or commands?

I was using macos in VM and bought a macbook thinking it was a virtualization issue but it seems to be a weird side affect of the ancient requirements fbs still is expecting :frowning:

Hoping someone could shed some light on the current supported way to do this.

So after months off and on of struggling with this nonsense was going to just fork fbs and make it work with python 3.8 and latest pyinstaller. So tested a new minimal project with fbs python 3.8 and pyinstaller 4.0 and worked in linux so went to try it in Macos it was a big NOPE.jpg.

Couldn’t get pyinstaller 4.0 to work with python 3.8 in macosx cause of some weird setuptools oddities which was a long waste of time.

Ended up uninstalling homebrew pyqt and then grabbing the official installer from : Python Releases for macOS |

Download macOS 64-bit installer: python-3.6.8-macosx10.6.pkg

Then installed the base requirements.

Then i did a force install of the newer pyinstaller==4.0

pip install pyinstaller==4.0 pyinstaller-hooks-contrib==2020.9

This apparently has all the fixes which aren’t in the pinned requirements for pyinstaller==3.4 which FBS wants. Also tried pyinstaller==3.6 and it did not work either.

Winning combination seems to be
macOS 64-bit installer: python-3.6.8-macosx10.6.pkg

With the below and FBS latest.

I had previously tried the python 3.6.5 and it hadn’t worked either.

I did not have to do much to fix the app besides copy some of my app resources from resources folder to the Macos folder after freezing.

Hopefully this helps others out with the QTWebengine and other missing dylib issues when packaging on mac with fbs.

So pleased now as it just works.