System tray examples not showing up on Windows 10

I just started this tutorial: System tray & Mac menu bar applications in PyQt
I am using a Windows 10 computer. When I run the two example code blocks in the tutorial, nothing happens. I have to force the programs to stop executing. The icons are not showing up anywhere that I can see. Please can you help me to get this running? I have searched online and haven’t found a solution yet. Other examples from other sites also have this issue.
Thank you.

Just to add, I have been able to get an icon to appear using an example from stackoverflow but unfortunately nothing happens and the program just keeps running because I can’t exit.

Here’s the code from python - PyQt: Show menu in a system tray application - Stack Overflow

import sys
from PyQt5 import QtWidgets, QtCore, QtGui
class SystemTrayIcon(QtWidgets.QSystemTrayIcon):
def init(self, icon, parent=None):
QtWidgets.QSystemTrayIcon.init(self, icon, parent)
menu = QtWidgets.QMenu(parent)
exitAction = menu.addAction(“Exit”)
def exit(self):
def main(image):
app = QtWidgets.QApplication(sys.argv)
w = QtWidgets.QWidget()
trayIcon = SystemTrayIcon(image, w)
if name == ‘main’:

Hey @Virginia I have just tested the example now on Windows 10 and it works fine for me. I did notice though that when I didn’t have the icon available it wouldn’t show anything in the system tray. The code as-is expects the icon.png to be in the same folder as the script.


You could of course use the built-in icons we discovered recently.

# Create the icon
style =
icon = QIcon(style.standardIcon(QStyle.SP_TitleBarMenuButton))


(SP_TitleBarMenuButton is the Qt icon on the left)

To add a quit option to the menu you can add another action e.g.

quit = QAction("Quit")

I’ll add this to the article.

The icon was in the same folder, and it still didn’t work. However now when I run it, your code is working - sort of. The icon shows up in the system tray, and I can right click on it to access the dropdown. This problem may be related to my software - Spyder is behaving strangely. Sometimes when I run it, the icon shows up and it works fine. Other times it shows up, but in the hidden icons - I have to expand my system tray to see it. Then I can “quit” and the code stops but the icon is still there. Normally when I close something in the system tray, the icon disappears. Maybe that is what happened before - it ran but the system tray put it with the hidden icons. I also didn’t pick up on the fact that I was supposed to right click on it, not left click. The code from Stack Overflow works now too. Maybe this is Spyder’s issue.

Thank you for adding the “quit” button - before I was having trouble getting it to stop running because Spyder doesn’t always respond to break commands. That was what caused a large amount of my problems earlier. Then I was left clicking instead of right clicking when I tried the other code.

How long does the icon hang around after you quit? If it’s via the “Quit” menu icon it should be fairly quick (a few seconds). If you quit the command window it was launched from the process is sill going for a while, so it will take a bit longer. It could be Windows hiding all the icons together you’re right.

@ Virginia

In the past, I have used Spyder and Eric6, Pycharm. I have keep Pycharm and remove Spyder and Eric6.

Pycharm is really a great IDE done in Java (search the error) for Python (and Django too but not with the community version).

Since Martin’s tutorials, I also use Qt Creator which is really great and complementary to Pycharm.
I understand very well what you are living with your IDE because I lived it too.

I don’t know if we can share some files in PM but I could send you a basic tray app that I have done based in a big part with the system tray tutorial. This app is basic and do nothing. Under to display it in the systray and show a bunch of action with their respective icons. This can be helpful for you to know if it s come from you or your IDE . I will include the icons folder with and all the links in the code.


1 Like

Thank you very much, Eolinwen! I have Anaconda Navigator, which included Spyder and some other code editors. I took your advice and tried it in a different IDE - Jupyter Notebook. This does the same thing. The code stops running, but the icon remains. I can see using the Task Manager that, even after I close Jupyter Notebook, I have to use the task manager end the task jupyter-notebook.exe to get the icon to go away. It’s possible that the script is very, very slow to stop and that it would stop on its own, but I think I have to force it with the task manager.

I’m not sure if I want to keep playing around with scripts that aren’t completely stopping right now - I think I should move on and focus on some different tutorials, then maybe come back to this later - but I would appreciate it if you could send me another program to test, just to try one more example. I tried the one from Stack Overflow again and it’s now crashing both IDE’s.

Thank you again for your help.

It’s hanging on after I quit via the menu icon, and it seems like I have to shut the IDE down and sometimes also have to use the Task Manager to get the icon to go away (although the menu no longer appears).

Weird. Have you tried running it from the command line – as in, save it to a file and then execute it with python outside of an IDE?

If it doesn’t return after the app.quit() call then it suggests it’s not shutting down the main loop cleanly, I’ll have a dig there might be some step I’ve missed to do this properly.

Thank you for suggesting that. It works fine in the command line, but in the IDEs I have to basically force it to shut down with the Task Manager. At least I know that if I do decide to make an app with this feature, I can run it that way. Does this have something to do with kernels?

I have had the same issue there are a long time ago when I have tried this one. I have removed it more quickly than I have installed. In fact , I had the same issue using Ipyhton in spyder (which is also used by Jupyter) . My kernel was died and nothing was responding. Obliged to kill the app.

Try Pycharm community (you can get in Anaconda I have checked) After you 'll Adopt it and love it. This IDE is really done for Python and PyQt5.

To check if it comes from your IDE (or anaconda rather), we are going together a little thing.

  1. Create a folder that you name like you want

  2. Copie/paste the following file with the name that you want in a python file. For me it is

    import os

    from PyQt5.QtGui import QIcon
    from PyQt5.QtWidgets import QApplication, QSystemTrayIcon, QMenu, QAction

    app = QApplication([])

    #Création de l'icone qui se situe dans le dossier image
    icon_path_tray = os.path.join(os.path.dirname(__file__), "images/mascot.png")
    tray_icon = QIcon(icon_path_tray)

    #Création du tray
    tray_menu = QSystemTrayIcon()

    #Création du menu
    menulist_tray = QMenu()

    #Display another icon
    icon_path = os.path.join(os.path.dirname(__file__), "images/")

    #Show the main window
    actionshow = QAction(QIcon(os.path.join(icon_path, "desktop.png")), "Show Main Window")

    #Hide the main window
    actionHide = QAction(QIcon(os.path.join(icon_path, "mouse.png")), "Hide the Window")

    #add a separtor

    #add a help item
    actionHelp = QAction(QIcon(os.path.join(icon_path, "reboot.png")), "Help")

    #Quit the application
    actionQuit = QAction(QIcon(os.path.join(icon_path, "application-exit.png")), "Quit")

    #add a separator

    #Ajout du menu au tray

  1. Create a folder right next to the python file that you 'll call images.

  2. On pills (where you can add icons), download a icon theme (if it is not already done :stuck_out_tongue_winking_eye: ) put 4 icons.

  3. Rename this 4 icons with the following names :

  • desktop.png
  • mouse.png
  • reboot.png
  • application-exit.png

Finally, do 2 tests :

  • one opening a console in the first folder (where you have the python file) and run it (python

  • one with your IDE and see the result.

Normally, you should get the same result that the Deepin picture that I have shared with before (obviously, you 'll have some different icons).

Perhaps, that 's come from :

    app = QApplication([])

I have experimented some isssues with and I have replaced by (like I done usually):

app = QApplication(sys.argv])

You need to add at the beginning :

import sys

Normally, the main loop shouldn’t be at the end ?

Hi @Eolinwen! Thank you for these other suggestions about using sys and PyCharm. Unfortunately neither made a difference for the code from this tutorial site. I still had to shut it down in PyCharm manually. But I have confirmed, thanks to @Martin’s earlier suggestion, that it will shut down properly when run from the command line. That may be what I have to do for now whenever I want to run something with a system tray icon. I will try your code later.

I added a ‘quit’ action to this code, which has no actions, and it does the same thing as the other code. It’s possible that the ‘quit’ command is part of the issue, but using other similar commands such as ‘exit’ doesn’t change the outcome. I think this may be part of a more general issue. It seems from my web searches that other people have problems with IDE’s not running or stopping programs.
However, I do know that I can run these in the terminal.
Thank you again for all your help on this issue.

I have now discovered, based on advice I found here QSystemTrayIcon Example · GitHub
that if I replace PyQt5 with PySide2, and run it in PyCharm with a virtual environment that does not have PyQt5 in it, it works as expected. However I have not been able to get that to work in Spyder yet because of issues with Spyder and PySide2. I haven’t tried it in any other IDE’s yet. Now I have at least one option beyond using the terminal.